Pacificmeister Build Info and CAD Sources


Thanks for adding Rev 3 duct and prop @pacificmeister!
The prop 3blade rev3 STL appears to be scaled 10x larger, so scaled down in Simplify3D


I did the same thing in Cura. Printed the prop, duct is on the bed and they look great!


@pacificmeister Hi, the rev3 for the duct and propeller are the same as Parametric Propeller & Duct Design - Fusion 360 ?
I try this but after one hour, I lose the shaft and of course the propeller. For the new, I will glued the shaft.


Same ring size and profile but I made the struts a bit thicker in REV3. Hope the shaft stays on.


Thanks. When I lost the shaft and propeller, I think the propelller broke the duct (rev2) when she left.


Hi Justin, I was wondering if you could pass me the measure of the ditancias between holes of liquid force fuelage

I’ll thank you so much


hi Guys just looking for a bit of help
I had my first test other week and all went well
Stripped it down to check water etc. Put it back together and then I had issues with my remote not working right,
Before in zero position which is centre it would be no throttle but now, I have to push the throttle away to keep it zero throttle, this is the same for a couple of remotes I have tried. So when I power up the esc beeps fast 1 sec intervals and when nothing happens until I push the throttle away from the zero position then it beeps and seem to put the zero throttle position to this position, so if I let go of throttle it’s running half speed. Full speed if I pull towards me Hope I explained it so anyone can understand me
Has anyone else had similar issues


I guess you’ve to calibrate your ESC for that transmitter. Or check if your remote has an offset setup, like a rotary switch that moves the idle (zero throttle) further away from center throttle stick. I’ve one of them that wants full throttle/min and then take those values as max/min.


I tried all the offsets and still the same , funny thing is I was out on last week all fine… y esc beeping which it never done before only on pairing
Spinning me out


I had something similar with 2 tx’s. 1st had minimum throttle (i guess some kind of a failsafe) of 25% at 0 throttle right after arming. It was disabled by default but i guess it turned on somehow when i was testing channels. 2nd was calibrating issue. Motor didnt spin very linear with the gas, even if i set up everything in tx settings. Also, tried different reciever, had to reverse some channels to make it properly work. What solved the problem was 4th calibration. U can also try to change modes (sometimes there are preseted settings for different modes) in your tx and check is any channel reversed by default or got reversed in the process.



I solved the problem now , it was when i was calibrating the throttle i pushed it away. all good now


@pacificmeister what is your method of connecting the straps around the pelican case to the board? Do you have some sort of bolted anchor for the straps to go around epoxied to the foam?


I cannot answer for Pacific, but my method can be seen here at 10:10


Just used thick screws into the carbon walls with these plates, some epoxy around.


I’m designing a modified MastClampBack which does not involve using any glue. The idea was to use two O-Rings for sealing the tube attachment (similar to what @pacificmeister did in the SealMount) and using cable glands (PG-7) for the cables. I think I finally managed to prove this is a reliable solution.

Here is the design:
I use the following model for the PG7 threads:
I’m not sure if it is needed for editing the model. Installation instructions are in the github repo.

And here are some pictures:

Next, I’m going to:

  • See that I know how to drill holes for 2 or 3 screws which will hold the tube in place (without leaks).
  • Attach the rest of the MastClampBack model (I’m probably going to remodel the entire clamp, as my mast is too long to be fit in the existing model, and I also want to have better guide for the wires into their holes.

Any input is most welcome.


In case someone wonders, this is printed in 100% PETG (in my prusa MK3, with 240 degrees). I did not use any external sealer yet, but I intent to use this one:


Epoxy and Petg are not so compatible, I used Petg to build surf fin molds because epoxy parts give up easily, with just little wax demolding is a brief. Maybe that resin will stick better…I don’t know. I know that I had problem of waterproofing with petg, never with ASA nor with Polycarbonate.


I’ll test the XTC-3D material tomorrow, but I think you have a valid point (if epoxy doesn’t stick to PETG, that will not allow even coating). Thanks for pointing it out. I guess I should have read the manual page of XTC-3D, PETG is not mentioned as supported material.

I remember seeing Apollo X mentioned here as a suggested ASA filament. I’ll see how I can source it here (or another ASA brand).


I did. Mine was an oval measuring about 58x64 and rather consistent across the length too. I let Amazon know and the seller sent me another that was pretty much round, maybe a 1/2 mm variance


Very nice. Let us know how it works when you tested it. I started a similar design last year with a smaller 50mm motor but I never finished it. Tightening the cable glands in this tight space is tricky and you will likely add an inch or so to your pod length. But nice to be able to service things. Good luck.