Is this VESC behaviour normal?


#1

Somehow the motor starts spinning at different throttle positions and I cannot adjust the speed. It is all or nothing. Somebody suggested this is because I don’t have a losd on it. The VESC is driving me mad. Everything else of the build was essy compared to getting this running.


#2

Use dutycycle control instead of current control…


#3

Man, I had a complete troubleshooting guid almost typed out. Then at @Giga spotted the error. But be fair, it’s only shown quite brievly in focus in the video :flushed: With current control it is supposed to accelerate to the max speed possible with the current you allow on your remote. So with no load this is about max speed.


#4

I’m sorry, did you already abandon it? I guess a troubleshooting guide is quite handy for new users of the VESC. So if you still have it, leave it here for the community!

to be honest, I didnt even watch the video. His description already pointed it out…for somebody who already had the same “issue” :smile:

Exactly, current control is almost the same as power control, so if you push the throttle a tiny bit and thus allow the ESC/motor to have like 3% of the max power, for max amp at 100A this is already 3A, which is more than your motor needs idle. Conclusion: your trigger is not sensitive enough to control your motor speed without load. (but in practices it doesnt have to, so either change to dutycycle control for testing, or keep at current (pun not intended) settings and try it out in the water).
I also can recommend the ACKManiac Android App and a cheap HM-10, so you can quickly change between profiles (and also set max power/RPM).


#5

Well it was not endlessly much, but you solved the problem much quicker. It’s still available above if you look at the verision of my reply before the edit … Here it is, maybe someone gets a clue from it in the future:

It’s always hard when there is something wierd with electronics, because the problems are not easily visible. But with some diagnosis you will get there.

I have some suggestions on what you can try. First of all, maybe it’s only some problem with your input method. You can try to go to the realtime tab in the vesc tool. Then you can select your duty cyle which should be proportional to your motor’s speed. To be clear:
http://efoil.builders/uploads/default/original/2X/1/14cfba990ec30a0959b5046034e73b1ba1723dd4.png

Then i want to mention, that all setting changes are not per default written to the vesc. You probably know this, but the best method is to always load the motor parameters and app settings with the “A up” and “M up” buttons from the vesc to the tool. Then change something and write the changes with “A down” and “M down” buttons on the right to to the vesc to have some effect. Especially with the input and motor setup wizards make sure you save all the values.

What “BLDC” and “FOC” and “DC” means unter General Motor settings is different contorol shemes. “DC” is obviously for simple direct current motors and not for brushless motors that we use. “BLDC” and “FOC” are both for the brushless motors we are using. But FOC is a much more complicated control sheme and harder to get right. You might want to try “BLDC” mode. Your motor might be noisier and have less startup torque, but those are things I consider less important for efoils.

Then you might allow the Vesc some braking current and some battery charge current, maybe 5A. There is no real reason behind this. It is just more common and maybe helps.

One problem that bugged me for an hour is when I set the unter voltage protection too hard and my motor would only creep when testing with the lab psu. You have the untervoltage cutoff values quite high, although they shoud be fine. You can watch the Volts In in the realtime tab while running. Maybe adjust it to 12X3V=36V?

As a last thing I would offer you to look over your settings completely, maybe I can spot something obvious. You can export motor and app settings as XML Files. Load your Motor and App settings from the Vesc to the “Vesc Tool” and then export them with File->“Save Motor/App Configuration XML as…”.


#6

We tested the vesc as well…You can use current control as well. Under load it will react correctly;-) and not get max rpm with only small input on the trigger;-)
We had another issue with the VESC, we could not get maximum power out of it. Our maximum value was 30A only allthough 60A should be possible…
Anyone tested it under load allready and got more power out of it? All our limits were set above 100A so this should not be the issue. Seems the BLDC mode is not perfect for brushless motors. With same setup we can go up to 150 A with different ESC, so other components can`t be the problem…