Battery trouble

The battery LED blinks red and can no longer be charged.
This seems to be because the power of eFoil was turned off before the update was completed.
When I contacted LIFT, I was told that I need to replace it with a new battery.
Does anyone know how to use the battery?

Does your battery have any other connectors or wires except main + and - ? Do you have multimeter?

There are two places to plug the main cable and data cable. There is no multimeter.
There are no other buttons.

The battery manufacturer is LITHOS.
The manufacturer of the charger is delta-α.eFoil_Battery

LIFT should :thinking:
20char

I followed the update on lift , it seems to be pretty « elaborated » set up with bms sealed in the battery that gives information for esc , there is a lot of fail safe and if one of the component is down , I guess the way I see , will be to buy a new battery and sell the one another for components
Sorry to say that was an expensive update , every time I update my vesc I cross fingers

I would cry to lift saying there to much fail safe on the board and apparently none for the firmware update and i will read the waranty about trouble when doing this

after watching some lift foil videos, I see that battery has smart bms which is always connected to esc.
it would be stupid to throw whole battery because probably cheapest component doesn’t work anymore. Try to talk to lift foil guys, if they could send you new bms, or if they will replace/fix battery for price that is lower than 3500$
or like @Alexandre says, scrap battery for cells. in this case, you will get smallest amount of money back.

Where are you based?
What was updating?
Have you measured the battery voltage with a multimeter?

Nice Business model.
Bricking battery during update, that you have to buy a new one :astonished:
Just thinking about those phones of a known Brand. Silly if a OS update would result in Millions of bricked phones and everyone would have to buy a new one

Thank you for your opinions.

The charger has a USB port. Is there a way to forcibly reset BMS of LITHOS battery?

Were you updating the BMS through the USB when the power went off? Giving a better idea of what was updating and how would help us diagnose what may be the issue and what your next steps should be.

Update via bleutooth with lift app
Usb on charger is to set the voltage on the charger only since it is a generic charger

Power is needed to do the update , the only way I think is to power the esc through the plug with a external battery , living only the data cable connected to the lift battery and esc , see if you can get communication with the app and if the data cable power the bms inside the battery box , then try to updated the new or the old firmware again
You may « break « the esc box …

Update via bleutooth with lift app.
I have never used a USB port.